Jump to content
  • 0
Grizz1ee

Scripthook wont work

Question

I keep trying to use the script hook and every time i do it won't let me. I tried turning off battle hook in the launcher arguments and then it let me launch but then the mod menu didn't work when i pressed the key binds. Don't know where to go from here.

7c0e92fc0620ba8addfa648e01271c35.png

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Can you check if you have a log file? It should be in <game>/bin/ScriptHook/ folder.
Do you see the "ScriptHook initialized" text when the game boots?

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Freaky said:

Can you check if you have a log file? It should be in <game>/bin/ScriptHook/ folder.
Do you see the "ScriptHook initialized" text when the game boots?

No i doesn't say scripthook initialized all it says is

[   3.540912] <Info> [GameVersionDetection] Detected uplay-4.51.dx12
[   3.598375] <Info> [ui::DataManager] Loaded C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch Dogs Legion\bin\ScriptHook\data\ui\styles/default/application.json
[   3.598910] <Info> [ui::DataManager] Loaded C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch Dogs Legion\bin\ScriptHook\data\ui\styles/default/default.json
[   3.599087] <Info> [ui::DataManager] Loaded C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch Dogs Legion\bin\ScriptHook\data\ui\styles/default/docking.json
[   3.599420] <Info> [ui::DataManager] Loaded C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch Dogs Legion\bin\ScriptHook\data\ui\styles/default/game-controls.json
[   3.600060] <Info> [ui::DataManager] Loaded C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch Dogs Legion\bin\ScriptHook\data\ui\styles/default/simple-menu.json
[   3.600397] <Info> [ui::DataManager] Loaded C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Watch Dogs Legion\bin\ScriptHook\data\ui\styles/default/startup-menu.json
[   3.724579] <Warning> Device lost, releasing 5 resources...
[   3.725158] <Warning> Device reset, recreating 5 resources...

Share this post


Link to post
Share on other sites
  • 0

Are you using some kind of overlays? (OBS, Discord, etc.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Nomad Group

We are a dedicated team of software & game developers, reverse engineers and most importantly gaming enthusiasts.

Our team has developed dozens of mods and toolkits and contributed to major multiplayer and game projects over the past years.

Useful Links

Legal Statement

NOMAD Group and the contents herein, are not affiliated with Ubisoft or Take-two Interactive Software Inc.

Watch_Dogs, Watch_Dogs 2 and Watch_Dogs Legion are registered trademarks of Ubisoft.

Mafia 2, Mafia Definitive Edition are registered trademarks of Take-Two Interactive Software Inc.

×
×
  • Create New...